--=REKLAMA=--

Wymagania instalacyjne

Z Joomla!WikiPL

Wersja Zwiastun (dyskusja | edycje) z dnia 11:31, 14 lip 2014

(różn.) ← poprzednia wersja | przejdź do aktualnej wersji (różn.) | następna wersja → (różn.)

Więcej informacji można znaleźć na stronie Joomla.org.

Joomla 3.x Joomla w wersji 3.x

Oprogramowanie Zalecane Minimum
PHP (wyłączone Magic Quotes GPC) 5.3.10 + 5.3.10 +
Obsługiwane bazy danych:
MySQL[1] (wymagana obsługa InnoDB) 5.1 + 5.1 +
MSSQL 10.50.1600.1 + 10.50.1600.1 +
PostgreSQL 8.3.18 + 8.3.18 +
Obsługiwane serwery:
Apache(z mod_mysql, mod_xml, and mod_zlib)[2][3] 2.x+ 2.x+
Nginx 1.1 1.0
Microsoft IIS 7 7

Joomla 2.5.x Joomla! w wersji 2.5 - 1.7.x J 17.png - 1.6.x J 16.png

Oprogramowanie Zalecane Minimum
PHP 5.3+ 5.2.4+
Obsługiwane bazy danych:
MySQL[1] 5.0.4+ 5.0.4+
Obsługiwane serwery:
Apache (z mod_mysql, mod_xml, and mod_zlib)[2][3] 2.x+ 2.x+
Nginx 1.1 1.0
Microsoft IIS[4] 7 7

Joomla 1.5.x Joomla w wersji 1.5.x

Oprogramowanie Zalecane Minimum Nie testowano[5]
PHP[6] 5.2 or 5.3 4.3.10 5.4+
Obsługiwane bazy danych:
MySQL[1] 4.1.x+ 3.23
Obsługiwane serwery:
Apache (z mod_mysql, mod_xml, and mod_zlib)[2][3] 2.x+ 1.3
Dla Microsoft IIS[7] 7 6


Uwagi

Jeśli chcesz wykorzystać do roboczej instalacji lokalny komputer, możesz posłużyć się jednym z poniższych pakietów, które pozwolą szybko stworzyć odpowiednie środowisko testowe:

Jeżeli potrzebujesz innych opcji, poszukaj informacji na naszym forum, poświęconym instalacji Joomla!.

Zobacz także

Przypisy

Przypisy


  1. 1,0 1,1 1,2 Joomla nie jest kompatybilny z MySQL 6.x.
  2. 2,0 2,1 2,2 Aby korzystać z prostych adresów, musisz mieć zainstalowane rozszerzenie mod_rewrite.
  3. 3,0 3,1 3,2 Rozszerzenia mod_suphp albo mod_fcgid są zalecane, aby umożliwić Joomla ładowanie i wykonywanie plików, gdy w środowisku stosowane są bezpieczne uprawnienia plików.
  4. W przypadku IIS niezbędne MySQL 5.1 lub nowsze.
  5. Projekt Joomla nie testował obsługi oprogramowania wymienionego w tej kolumnie. Joomla moze poprawnie działać z tymi wersjami oprogramowania, ale oficjalnie nie są one wspierane.
  6. Nie korzystaj z wersji PHP 4.3.9, 4.4.2 oraz 5.0.4. Te wydania zawierają błędy, które będą przeszkadzać w instalacji. Zend Optimizer 2.5.10 dla PHP 4.4.x również ma poważne błędy i powinieneś poprosić swego usługodawcę, by unowocześnił swoje środowisko, jeśli akurat używa tej wersji. Wydania Joomla 1.5.15 i wyższe są kompatybilne z PHP 5.3. Zwróć uwagę, że biblioteka OpenID nie jest kompatybilna z PHP 5.3.
  7. zależnie od Twojej infrastruktury, możesz potrzebować następującego oprogramowania:

Dziękujemy za wkład

» Stefan Wajda [zwiastun],